Hidden Features

(Redirected from Scratch Secrets)

"Shift Secrets" redirects here. For this article in Scratch 1.4, see Shift Secrets (1.4).

Scratch 2.0 has many hidden features dealing with clicking on a specific object or screen region while holding down the ⇧ Shift key, ctrl key, or command key. Typically, these secrets are used to hide advanced features that would confuse a beginner who is new to Scratch.

File Menu

The offline and online editor have slightly different hidden options when shift-clicking the "File" menu. In the online editor, the option Save Project Summary Appears. However, when shift-clicking in the offline editor, another option appears: "Import Experimental Extension".

Edit Menu

The shift-click accessible Edit menu options.

In the online editor, shift-clicking the Edit menu at the top of the program opens many options, including the Motor Blocks. The following contains all the options, including the normal ones:

Turbo Mode

Shift-clicking the green flag runs the project in turbo mode, which runs the project extremely fast, having minimal to no wait between blocks. This is useful for solving large mathematical operations or running a 3D engine smoothly.

Muting

Holding the ctrl key (command key on Mac OS X) and clicking the green flag runs the project with no sound. This is useful for quickly muting a project.

Lists

Pressing ⇧ Shift+↵ Enter while editing a list item will create a new item after it. Pressing the Tab ⇆ key while editing a list item will move the cursor to the next item, and pressing Tab ⇆+⇧ Shift while will move the cursor to the previous item.

Block Arguments

Pressing the Tab ⇆ key while editing an argument will move the cursor to the next editable argument in a block, and pressing Tab ⇆+⇧ Shift while editing an argument will move the cursor to the previous editable argument.

Tool Buttons

Deleting a sprite with the "scissors" tool.

The top bar of the Scratch program contains stamper, scissors, outward arrows, inward arrows, and question mark buttons. After being selected, they can be used to duplicate and delete sprites, blocks, comments, costumes, and sounds, grow and shrink sprites and costumes, or get help for a block or specific part of the program. However, after performing that operation, typically the tool must be selected to perform the task again. As an alternative to the repetitively selecting the tool, one can hold down the ⇧ Shift key to use the tool multiple times without it exiting and requiring selection again.

Costumes/Sprites

When importing a new sprite, the ⇧ Shift key can be held down to import multiple sprites. Clicking on a selected sprite will deselect it, and vice versa. The same is true when importing costumes.

Paint Editor

The paint editor itself has multiple features using the ⇧ Shift key.

Duplicate Tool

When using the "duplicate tool" (stamper) in the vector editor, holding down the ⇧ Shift key while stamping allows one to continuously stamp the same object without the need to re-select it.

Spline Manipulation

The Scratch 2.0 vector editor uses splines (control points) to store information on an image instead of a bitmap's array of pixels. When modifying these splines with the reshape tool, one can shift-click on a spline to disconnect that point from the object (split it at the location). Additionally, shift-clicking between two splines creates a new spline which has a smooth bend and curvature relative to the two adjacent splines.

Perfect Shapes

When drawing a rectangle, holding down the shift key makes it a square, with each side the same length. When drawing an oval, holding down the shift key makes it a perfect circle. This feature can be useful for drawing exact, unifying shapes, and for demonstrative purposes in a mathematical tutorial project. You can also hold the ⇧ Shift key when drawing lines to make them perfectly straight.

Sound Editor

The sound editor has two features using the ⇧ Shift key.

Cropping Sounds

Cropping sounds can be accomplished more easily by highlighting the area you want to keep and deleting the rest of the file. When a sound section is highlighted, one can hit ⇧ Shift+delete or ⇧ Shift+← Backspace to keep the highlighted section and remove the rest of the sound, cropping it to the desired section.

Applying Effects

Shift-clicking the effects menu and selecting "louder" or "softer" will change the volume at a smaller interval than by doing so without holding shift.

Scrolling

In the scripts area and other places with a scroll bar, holding down the ⇧ Shift key and scrolling down on the scroll wheel will scroll right, and holding down the shift key and scrolling up on the scroll wheel will scroll left.

Rendering

Pressing ctrl+m (command+m on Mac OS X) will make Scratch toggle between using the Pixel Bender and Stage3D rendering engines. This is likely intended by the Scratch Team to be used for testing.

See Also

  • This page was last modified on 21 October 2014, at 22:31.