Ribbon Bar

The ribbon bar as seen from the top of the Scratch interface.
The Ribbon Bar is a narrow strip of dark grey at the top of the Scratch Interface containing some context menus, tools, links, and options. It is always present and cannot be collapsed unlike ribbons in some other computer programs such as Microsoft Office.


Accessing the Ribbon Bar

To access the ribbon bar, the Scratch program must first be opened. Once complete, the ribbon bar automatically appears at the top of the interface. Its features can be accessed by using the mouse pointer to click on the desired function. The ribbon is divided into three subsections containing similar options.

Content

Scratch Home Page Link

Hovering over the home page link adjusts the colors to indicate it can be clicked.
The top-left of the ribbon bar contains the word "Scratch" written in Scratch font. Hovering the mouse over it will adjust the colors to indicate it can be clicked. Clicking the text/button will direct the web browser to the Scratch home page. It does not open the home page in a new tab but will replace the project editor. It cannot be right-clicked either to open the home page in a different tab.

Language Menu

The globe button drops-down a list of other languages.
Scratch is available in dozens of languages. The "globe" image in the ribbon bar contains a drop-down menu of all the available languages the Scratch program can be changed to. Hovering over the globe will change its color to orange to indicate it can be clicked. The languages are written in their own tongue; for example, Spanish is written as "Español" so native Spanish speakers understand it is their language.

File Menu

Main article: File Menu

The file menu contains options for the following: creating a new blank Scratch project, saving the current project either to the Scratch servers of one's local computer, reverting a project to its initial state upon being opened, going to My Stuff, recording video, and more. If the menu is shift-clicked some extra options appear.

Edit Menu

Main article: Edit Menu

The edit menu contains options for the following: Undeleting the last-deleted object, switching to a small-stage layout, and enabling turbo mode. If the menu is shift-clicked, extra, advanced options appear such as exporting files containing string data, "Edit Block Colors", viewing the JSON file, and more.

Tips

The "Tips" text is a button that opens the tips window on the right-hand side of the Scratch interface. This window can provide useful insight for anybody struggling to develop a project. It is especially useful for new Scratchers who have little experience.

Duplicate

Once selected, the stamp will replace the mouse-pointer image until it is clicked somewhere.
The duplicate button is part of the center and second subsection of the ribbon bar. Clicking it brings up a stamp-like figure that replaces the mouse-pointer. By clicking on a sprite, the sprite will be duplicated. If the stamp button is clicked by mistake, it can be negated by clicking in a plain area of the project editor.

Delete (Scissors)

The "delete" widget, resembled by the image of a pair of scissors, is an alternative method of deleting sprites. Clicking on the tool will replace the mouse-pointer with an image of scissors. Then, clicking on a sprite will delete that sprite. If a sprite is deleted by mistake, the action can be undone from the Edit menu. If there is no desire to delete a sprite, clicking in any plain area of the Scratch editor will terminate the process.

Grow

The "grow" button is an option for quickly increasing the size of a sprite; it is an alternative to using looks blocks. Clicking on the tool will replace the mouse-pointer with its image. Then, clicking on a sprite will increase the size of the sprite. To cancel the process, simply click in any plain area of the editor.

Shrink

The "shrink" button works in the same manner as the "grow" button, except it decreases the size of the sprite. Clicking on the tool will replace the mouse-pointer with its image. Then, clicking on a sprite will decrease the size of the sprite. To cancel the process, simply click in any plain area of the editor.

Block Help

Hovering over the "block help" button.
Contrary to its name, the "Block Help" widget, denoted by a question mark enclosed in a circle, can provide help on topics beyond blocks. When the tool is selected, it will replace the mouse-pointer with an image of itself. Then, clicking on a block will pull up the tips window with information on how that block functions. It can also be clicked in various areas of the editor, in which case the tips window will display information on the various parts of the interface.

Options for a Logged-In User

Save Status

Manually saving a Scratch project.
Near the top-right is the last subsection of the ribbon bar which begins with the save status. If the project's current state is that which is saved, it will indicate so by displaying the text "Saved". If a block is moved, or anything is adjusted, it will adjust to the text "Save Now" which can be clicked to manually save the project. Scratch does automatically save the project frequently, but this is the easiest method of manually saving it. Alternatively, the project can be saved from the File menu.

My Stuff

Main article: My Stuff

The "envelope with an 'S'" button directs the web browser to My Stuff when clicked with the mouse-pointer. When hovered over with the mouse, its color changes to blue to indicate it can be clicked. "My Stuff" is a feature of the website that contains all the Scratch projects, both shared and unshared, of the logged-in user. The page will not open in a new tab but will replace the project editor.

Username and Associated Options

When logged in, one's username will be the right-most option of the ribbon bar. Clicking this will display a drop-down menu with the following options: "Profile", "My Stuff", "Account Settings", and "Log Out". There is a darker grey line between the last two options to isolate "Log Out". If signed out, the web browser will be directed to the Scratch home page.

Options for a Logged-Out User

Join Scratch

Options available only to someone who is not logged into a Scratch account.

Scratch projects cannot be saved in the online editor to the Scratch servers unless one has a Scratch account. One has the ability to create a Scratch account without closing their current work by clicking "Join Scratch" on the ribbon bar. When selected, the editor will be darkened out and a small menu will appear in the center of the screen with steps to creating a Scratch account. Once made, the project can then be saved to the Scratch servers so the work is not lost.

Warning Note: Alternatively, the project can be downloaded to one's personal computer from the File Menu to save a project.

Sign In

If one is logged out and is working on a project in the editor, he or she can sign in directly from the editor without ever closing the project. This can be accomplished with the "Sign in" button, which is right-most on the ribbon bar. When selected, the editor will become dark and a small menu will appear in the center of the screen where credentials can be entered. Once logged in, the project can be saved to the Scratch servers.

  • This page was last modified on 26 January 2017, at 19:04.